SharePoint Madness

All about SharePoint and Office365

Archive for the ‘SharePoint 2010 CU’ Category

Missing feature Id throws exception while installing SharePoint Patch/CU

Posted by Amit Bhatia on June 19, 2013

Hello friends!

I am writing this piece of blog to help the SharePoint administrator/developer understand one of the exceptions which comes up during CU installation on the SharePoint farm.

Exception information:

[OWSTIMER] [SPContentDatabaseSequence] [ERROR] [6/18/2013 7:40:05 PM]: Found a missing feature Id = [065c78be-5231-477e-a972-14177cc5b3c7]
[OWSTIMER] [SPContentDatabaseSequence] [ERROR] [6/18/2013 7:40:05 PM]: The feature with Id 065c78be-5231-477e-a972-14177cc5b3c7 is referenced in the database [WSS_Content_Lam_cn], but is not installed on the current farm. The missing feature may cause upgrade to fail. Please install any solution which contains the feature and restart upgrade if necessary.
[OWSTIMER] [SPContentDatabaseSequence] [ERROR] [6/18/2013 7:40:05 PM]: Found a missing feature Id = [0806d127-06e6-447a-980e-2e90b03101b8]

Cause:

There are some of the health rules which are absolutely critical to maintain the consistency of the farm environment. One such health rule is missing server dependencies. You need to remove unreferenced or old objects which do not have a reference within SharePoint in order to install the patch successfully.

Resolution:

  1. Go to SharePoint Central Administration site –> Monitoring –> Review problems and solutions
  2. Run the Missing Server dependencies rule in the SharePoint Health Analyzer rule to identify all the missing server dependencies.
  3. Once you identified all the missing server objects such features using feature id as identifier you may use the Feature admin tool or sharepoint admin tool from codeplex to remove them from SharePoint farm.
  4. You may use the below tool from codeplex to remove the faulty features >> http://featureadmin.codeplex.com/
  5. Once removed, you can run the health rules again using the health analyzer to ensure the rule run successfully without any errors.
  6. Try to install the patch again and run PSConfig using command line (advisable).

I hope this may help you to get around one of the frustrating exceptions while installing CU 🙂

Posted in SharePoint 2010, SharePoint 2010 CU | Leave a Comment »

PSConfig fails System.InvalidOperationException, “Cannot start service SPAdminv4 on computer ‘.'” after CU install

Posted by Amit Bhatia on October 3, 2012

If you’ve experienced this error (System.InvalidOperationException, “Cannot start service SPAdminv4 on computer ‘.’) after installing SharePoint 2010 and failing consistently at the SharePoint 2010 Products Configuration Wizard, then this is likely to help:

(1) Browse to C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\BIN

(2) In this directory Create a file called “WSSADMIN.EXE.CONFIG”

(3) Populate it with the following:

<configuration>
<runtime>
<generatePublisherEvidence enabled=”false”/>
</runtime>
</configuration>

This disables checking for CAS publisher policy. MSDN article, http://msdn.microsoft.com/en-us/library/bb629393.aspx

Posted in SharePoint 2010 CU | Tagged: , , | 7 Comments »

 
Searching For Value

Empowering Individual Investors

Ideas with Conviction

The best thing about investing is the ease with which you can move your capital across different businesses, helping you capitalize on every opportunity..

CFA Institute Enterprising Investor

Practical analysis for investment professionals

Journeys of a Bumbling Trader

Learnings and Thoughts on Trading, Macroeconomics, Value Investing, Quantitative Finance, and Accounting

Flirting with Models

Research Library of Newfound Research

Alpha Ideas

Investment Blog for the Indian Markets

Fundoo Professor

Thoughts of a teacher & practitioner of value investing and behavioral economics